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Macromedia Flash MX
Introduction 

Macromedia Flash MX is a powerful Web authoring application used to create animation, interactive enviroments and data driven applications for use on Web sites. Flash MX is one of the leading Web authoring programs for creating vector-based animations or "Flash movies" for Web sites. A working Flash document should have the file extension of .fla. A compiled Flash document exported to web is abreviated as a .swf file.

Flash creates vector-based graphics rather than bitmap graphics. Vector graphics are created using lines and curves, whereas bitmap graphics are described by pixels of color. Bitmap images are resolution dependent; therefore, resizing a bitmap image can lead to distortion. Vector-based graphics, on the other hand, are drawn using mathematical formulas. Resizing a vector-based image means the formula is recalculated, resulting in a scaled version of the original image and no distortion.

Flash MX supports the importing of bitmap graphics. This feature gives the Web developer a great deal of flexibility. The addition of a Flash movie to a Web site invites interactivity and provides an opportunity for visitors to have a more engaging experience.

NOTE: You must have the Flash MX application to open the .fla files found in the Examples section. A 30-day trial version is available at Macromedia.

Using Layers in Flash MX 

Layers are like clear sheets of acetate or glass. Layers can be stacked on top of each other. Each layer can have its own artwork, sound or action on it. Use as many layers as you need to keep everything separate and organized. Be consistent with the way you order and name layers, so that if you have to put the .fla away and work on it down the road, you won't be totally lost. This is a good practice to adopt. Suggested layer order and layer names are:

1. Actions --- any frame actions assigned can all be here.
2. Labels --- Name keyframes that have actions
3. Sounds --- Any sounds can be placed in keyframes here.
4. Object 1 (whatever you have on this layer)
5. Background

Name layers with short meaningful names that you will be able to identify at a glance. Such as "red ball bounce," or "button home." These aren't read by Flash, so they just have to have meaning to you.

NOTE: You can have as many layers as you want (or as your system can handle). Layers do not add to file size.

	Creating New Layers 
There are several ways to create a new layer: 

· Click on the “+” button in the lower left corner of the Timeline.
or, 
· From the Insert menu, choose Layer.
or, 
· Right–click (Windows) or Control+Click (Macintosh) on an existing layer and choose Insert Layer from the dropdown menu. 

view sample file
	[image: image22.jpg]Akt Layar

Hide/Shaw Layer -

Laekilniack Layer
| ¥ Timeline

] Guttine Viewe
Dagions

@ Labels

@ sounds

@ objects
@ Backgroung

et g Foder @ |

| &seenet







Create a guide layer by choosing Modify > Layer and selecting the "guide" option. A guide layer is used to help in drawing. Any layer can be made into a guide layer. The artwork appears in your work area, but not in the published movie. When you see this icon next to the layer name, then it is a guide layer. 
Layer Attributes
You can change the order of the layers by dragging them up or down in the Timeline.
The icons across the top of the Timeline control different attributes of the layers. 
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· The first changes the visibility of the layer to Off or On. This is helpful if you don't need to see that layer to work on a different layer. Even if you have the visibility of the layer turned Off, it will still show up in the published movie. If you want the layer to be visible, but not show up in the published movie, change the layer to a guide layer. The page icon on the layer will then change to a “t-square shape” 

· The Lock icon locks the layer so that you can't make changes on it. 

· The Box will change whatever artwork is on the layer into an outline. It will show up as the artwork, not as an outline in the movie. 

You can also change the height of the layer. This may be necessary if you have a sound file on a frame and you want to see the whole sound wave representation. To change the height, Control+Click on the layer (Macintosh) or right-click (Windows) and choose Properties. Adjust the layer height in the Layer Height box at the bottom of the menu box.


Exercise:
1. Create an object on a layer, click on the eye and test movie. You should see that even though the layer is invisible, the object shows up. (In order to test a movie, it must be saved first.) 

2. Change the object to an outline, and do the same thing. It should look the same. 

3. Change the layer type to a guide and test. Even though the object is visible, it won't show up in the test movie. 

Creating Colors in Flash MX
There are several ways to select color with Flash MX. The Swatches panel displays the 216 Web safe colors and also stores custom mixed colors created by the Mixer panel. To open the Swatches and Mixer panel, from the Windows menu and then Swatches and then Mixer. 
When working with colors in Flash, you may want to organize the Swatches, Mixer and Fill panels into one window. These three panels are used together very often with colors, and you can save and recall this panel layout. 

Adding a New Color to the Swatches Panel
· Click on the Mixer panel tab. Select the color swatch next to the bucket symbol. This is the Fill color. 
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Select another color from the drop down swatches menu or by using the sliders from the RGB sliders on the right. These sliders can be switched from RGB (Red, Green, Blue) to HSL (Hue, Saturation, Luminance) or HEX (Hexidecimal) using the left pointing arrow on the Mixer panel. 

· Adjust the transparency of the new color with the Alpha text box or slider. 

· When the color and transparency is set, select Add Swatch from the right pointing arrow on the Mixer panel. 

· Switch to the Swatches panel. The color you created is at the bottom of the color swatches. Now you have a custom swatch palette that you can save and call into other Flash sites. 

Saving a Custom Swatches Panel
Select the Swatches panel. Use the pull-down menu from the top right arrow and choose Save Colors. Save your swatches in your chosen directory. 

Adding a New Gradient Fill
Let's make a new gradient that has one solid color and one transparent color. 

· From the Swatches panel, choose the green radial gradient type. (You can change the type of gradient later.)

· From the upper right arrow choose Duplicate Swatch. 
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· To alter a portion of the gradient, select one of the color boxes under the bar that defines the gradient.
Next, use the "color fill" box above to choose another color. 

· Now select the other color and choose a new one. You can change the gradient type from the pull-down menu to create various types of gradients. 

· Change the gradient type to Linear. 

· Now look at your swatches and you'll see the new gradient you made at the end of the gradients. 

· Gradient color swatches can only be used in fills. Transparent fills can only be applied to new objects. They will not replace a fill already there. You will have to select and delete the fill before refilling with the transparent color. This might have to be a two-step process. If there is no stroke on your object, add a temporary one with the inkwell tool. Use that to define the area to be filled, then you can delete the stroke again. 
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Modifying the gradient's size, position and rotation inside of a filled object. 
· Make a shape and fill it with your newly created gradient. 

· Select the "fill transform" tool on the Toolbox. 
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Click on your filled shape on the stage.
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A center point appears in the center of the shape and with a Radial fill a circular transform modifier surrounds the shape. The square handle is an adjustment handle. Linear and Bitmap fills will a display a center point and two vertical lines on either side of the shape. On the right line, the square adjustment handle appears. 

· The Transform Fill handles allow you to change the size, position and rotation of the gradient fill inside the object. When you drag from the center point, the position of the fill will move. The square on the side changes the width, the circle directly below controls scale, and the other circle below that one controls the rotation of the fill. The mouse pointer will change when hovering over one of the handles to indicate the function. Try this with a linear fill to see the difference. In a linear fill, you can modify the same properties as well as skew or slant by dragging from one of the corners. 

Bitmap Fills
In the Fill panel, choose Bitmap from the Fill Menu. Click on a bitmap that appears in the Fill panel. You can modify a Bitmap fill the same as a Linear fill.

	Drawing in Flash MX
If you're familiar with Photoshop or other drawing, image manipulation and paint programs, then Flash tools will look familiar. Let's go over some of the drawing methods unique to Flash.

Overlapping Shapes
When one shape overlaps another and the two shapes are on the same layer and and are not selected, these objects merge into one object. You can still select one section of the object, but when you move it, the part of the other object that was overlapped will be erased. 

Exercise:
Draw a shape on the stage in one color. Draw an overlapping shape in another color. Select one of the color areas and drag the shape. You see that the part of the shape that was covered by the overlapping shape is gone. Keep this in mind when you're creating graphics. If you don't want this to happen, put the shapes on different layers, group them or make them symbols.

Pencil Tool
The Pencil tool works like a regular pencil tool with some cool options. The Pencil tool draws in three modes: Straighten, Smooth and Ink. These modes appear in the Options section of the Toolbox.

Choose Straighten and draw a box. The lines you draw have been straightened. Try this with the other two modes. Smooth makes nice curves averaged from the curve you drew. Ink leaves the line as you've drawn it.

Selecting edges and lines in Flash MX
· To select a line segment or the fill of an object, use the Arrow tool and click once over the line or fill. 

· Double clicking on a line will select all the curves in that line. 

· Choose the selection (Arrow) tool and deselect any shapes or lines that are on the stage. With the selection arrow, move it over one of the shape edges. The pointer arrow changes when you're over the edge of a shape that hasn't been grouped or made into a symbol. If it's over a curved line or curved edge of a fill, it is a pointer with a curve next to it and will move the curve if you press and drag. Over a corner or endpoint, it is a pointer with a corner, and will move the point or corner maintaining the straight lines. This will pull both stroke and fill alike. 

· To reshape lines and fills, select them. Use the Smooth or Straighten mode from the Modify Menu or from the Options section of the Toolbox. (You can adjust the amount of smoothing or straightening by choosing Preferences from the Edit menu.) 

· Control-drag (Windows) or option-drag (Macintosh) a line to create a new corner point. 

Optimizing Shapes
The fewer curved sections in a shape, the lower the amount of data Flash has to maintain on that shape. Optimizing shapes is highly recommended to reduce file size and increase playback speed of the Flash movie. To reduce the amount of curves in an object, choose Optimize from the Modify menu. The Optimize Curves dialog box allows you to reduce the number of curves contained in a shape. Observe the shape as you smooth it and stop before it changes the shape unacceptably. If it's a simple shape, the number of curves may not change at all. Optimizing all objects in a movie, can significantly reduce the movie file size and increase the playback speed.

Exercise:
Draw a shape. Select it and choose Optimize from the Modify menu. Use the slider to adjust the amount of smoothing to apply to the curve. (You can always choose Undo from the Edit menu.) The option 'Use multiple passes' will repeat the smoothing process until no more optimizing is possible. This is the same thing as choosing Optimize from the Modify menu over and over again.

Pen Tool
If you are familiar with Adobe Illustrator or Photoshop, Macromedia Freehand or Fireworks, you've seen this tool before. The Pen tool allows you to place points and create curves and lines that are repositionable.

Exercise to create a straight line:
· Select the Pen tool. 

· Click once anywhere in the stage window. 

· Click again, and a straight line is created between the two points. 

Exercise to create a curved line:
Position the Pen icon where you want it to begin on the stage. Press and hold the mouse and slide in the direction you want the curve to go. You'll see tangent handles that appear that you can also select and reposition. Release, and either repeat or just click where you want the curve to end. 

Exercise to modify a curve: 

Use the sub-selection tool to select a point or its selection handles and drag them to a new position.

Important points about curves: 

· To change a curve point to a corner point (or anchor point), use the Pen tool and just click on the point. 

· To change a corner or anchor point into a curve point, use the sub-selection tool, the option key and drag. 

· To delete a corner point, click on the point with the Pen tool. 

· To delete a curve point, double click on the point. 

· Fewer points means smaller file size. 

· A curve point is a hollow circle. 

· A corner point is hollow square. 

Brush Tool
The Brush tool is used to add color to your movie. The Brush tool has modifiers for Brush Size, Brush Shape and Modes. These modifiers are located in the Options section of the Toolbox. The Modes for the Brush tool provide different ways of painting. The Modes are:

Paint Normal - is just like you expect
Paint Fills - leaves strokes untouched 
Paint Behind - paints in back of 
Paint Selection - only paints selected item 
Paint Inside - paints only the fill you start in

If you're lucky enough to have a tablet and pressure-sensitive pen, then another option is available: the Pressure modifier. The Pressure modifier allows you to vary the thickness of the line you draw.

Exercise:
Create an object that has a fill and stroke. Select the Brush tool and try the different painting options.
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Making Buttons in Flash MX
One of the most powerful features of Flash MX is the interactivity you can build into your Web site. The button symbol is something you'll use often. Buttons can be as simple or as complex as you want. Buttons can contain movies and actions inside.

Buttons are actually interactive movies consisting of four frames. The first three frames define three states of the button, while the fourth frame defines the hit area, or the area that is "hot." The four frames are:

1. Up -- what button looks like in inactive state, when the pointer is not over the button;
2. Over -- what the button looks like when the pointer is over it;
3. Down – what the button looks like when the mouse is clicked on it; and
4. Hit -- the area that is “hot” that will trigger the button states. 

Exercise to build a simple button:
· From the Insert menu, choose New Symbol. In the Symbol Properties window that opens, choose Button as the Behavior type. Name it: b, simple button. Click OK. 

· This opens up the symbol editing window.
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You will see 4 labeled frames in the Layers and Timeline area. These frames represent the 4 states for your button: Up, Over, Down, and Hit. This is where you will create the artwork for the different states for your button. 

· Click in the “Up” state frame. 

· On the stage, draw a blue filled circle. The Up state is done. 

· To create the "Over", "Down" and "Hit" states, select each frame (state) and from the Insert menu choose Keyframe. This will put the last keyframe (Up state frame) in the selected frame. Then you can go back to each new frame and change the button. 

· We want the "Over" state of the button to look like the "Up" state except with a different fill color. 

· Select the "Over" state frame. If you click directly on the frame, it will select all objects in that frame. If you click over the frame, on the state label, it will go to the correct frame, but not select the objects in that frame. If the object is not selected, choose the selection arrow and select the blue filled circle on the “Over” state. While it is selected, choose a new color by the fill bucket to change the fill color. 

· Now select the "Down" state frame. Let's make the Down state a little different. Change the fill color to yellow the same way as in the Over state. Add some little dashes like radiating rays from the sun around the circle. 

· Let's leave the "Hit" state the way it is. 

· Click on the Scene 1 icon in the upper left hand corner of the work area. 

· If the Library window is not open, select Window/Library. (The key command will be indicated in the pull-down menu, if you'd rather use keys than the pull-down menus all the time.) 

· The simple button you made shows up in the Library list. 

· Select the button and the "Up" state of the button will appear in the upper portion of the Library window along with a right pointing arrow. Click this right pointing arrow and you'll see all four states of the button played. 

· Drag this button onto your stage. 

· To see your button in action, from the Control menu, select Enable Simple Buttons. Rollover your button and click on it. It should turn a different color when you roll over it, and turn into a yellow sun when you click on it. 

· See Example 1 in the Flash Examples section of this tutorial for the finished product. 

Exercise to create a button to perform an action: 

One of the most common button actions is to call up a different URL. We'll put this action on the button we just made and placed on the stage.

· From the Control menu turn off Enable Simple Buttons so you can interact with the button on the stage without testing the movie. 
(Enable Simple Buttons will not show you movies in keyframes.) 

· From the Window menu, choose Actions. This will open up the Object Actions window, one of the most powerful tools in Flash MX. Check and see that it is set on Normal mode and not Expert Mode by clicking on the arrow in the upper right corner. (Normal mode gives you clues and blanks to fill in with the proper syntax. Expert mode allows you to type in your own syntax.) For our purposes, we will choose Basic Actions from the list on the left hand side. Scroll through the list and select “Get URL”.Either double click on it, or drag it over to the right hand side. It will show up with the proper syntax, and an area to fill in on the bottom of the Object Actions window. (This action defaults to the “on release” action. If you want to change this, click on that line in the Object Actions window, and you'll see a new set of options for that line on the bottom.) With "Get URL" selected, Flash asks you for the URL you want this button to direct the user to. If you don't have a URL to use, type in this one: http://www.utexas.edu/ 

· Now you're ready to test your button. There are several ways to do this: 

1. from the Control menu, choose Test Movie or 

2. from the File menu, choose Publish Preview/HTML or 

3. from the File menu, choose Publish Preview/Flash. 

Test the button by rolling over it and clicking on it. 

· See Example 2 in the Flash Examples section of this tutorial for the finished product.

Exercise to create a fancier button:
· Select the b, simple button in the Library window. Click on the Options arrow and from the drop-down menu select Duplicate. Name this button 'copy b, movie button'. Leave the behavior as Button. Click OK. 

· Create a movie to place in the Down state of the button. 

· First, let's copy the sun and rays from the Down state of the simple button. 
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Click on the Symbols icon in the upper right hand corner of the stage, scroll down and choose your old button. The symbol editor opens.    

· Click on the Down frame, select the sun and rays, and from the Edit menu, choose Copy. 

· From the Insert menu, choose New Symbol. Select Movie Clip and name it 'm,sunny'. Click OK. The symbol editor is now open. 

· From the Edit menu, choose Paste in Place. You should see your sun from the “Down” state of the simple button. 

· From the Insert menu, choose Keyframes at frame 5 and frame 10. 

· Go to frame 5. Scale the sun up a little (i.e., make the image bigger). From the Modify menu, choose Transform and then Scale. Grab one of the square handles and make the image a little bigger. Now lets make a tween between keyframe 1 and 5, and 5 and 10. 

· Click on a frame between 1 and 5. The area on the Timeline turns black. 

· Now open the Frames panel. From the Window menu, choose Panels and then Frame. Choose Shape Tweening from the pull-down menu. (Shape tweening is for objects that have not been turned into symbols or grouped together. You can tell if it's a raw graphic by the selection. It will select and fill the object with black and white noise if its still raw. Grouped objects and symbols will have a bounding box instead. The shape tween is represented by a light green background with a solid line arrow on top. Dashed lines means something is not right.) 

· The tween should make a smooth upward scale between frame 1 and 5. Do the same thing between frame 5 and 10.

Let's make this even more fun.
· Add a layer above the scaling sun layer. Name it 'spiral.' Double-click on the Layer to change the layer name. 

· Insert a keyframe on the first frame. 

· Select the first frame on the spiral layer and draw a darker yellow or orange spiral on top of the sun. 

· Select the spiral and make it a symbol by choosing Convert to Symbol from the Insert menu. Name it 'm,spiral movie clip.' The behavior is movie clip. 

· Create a Keyframe in frame 10. 

· Select frame 10 which still contains the unconverted graphic. Select the image, delete it and drag the spiral symbol from the Library window into its place. You can use the arrow keys to line up the center crosshairs. It should be in registration with the first one on the first frame. 

· Let's make the spiral rotate one complete revolution for 10 frames. Select the area between frames 1 and 10 and open the Frame panel (from the Window menu, chooose Panels and then Frame). In the Tweening box select Motion. In Motion Tweening, you can indicate the direction of the Rotation. Select CCW for counter-clockwise. In the "times" box, put 1 for 1 revolution. Motion tweens work on symbols. The tween on the Timeline will look blue, with a solid line arrow. 

· Create a new layer and move it to the top. Call it 'actions.' 

· On the actions layer, select frame 10 and insert a keyframe by choosing Keyframe from the Insert menu. 

· Choose Window/Actions. The Frame Actions window opens. 

· Select Basic Actions and “Go To." It will be an action on this frame sending it to a frame number or label. It defaults to frame 1 which is fine in this case. Now this movie will loop endlessly. (The timelines in movies are independent of the Timeline on the main stage, so frame 1 is unique to this movie.)

Putting the movie into the button
· Click on the symbols icon in the upper right hand corner and select 'copy b, movie button.' You are still in the symbol editor, but you are back in the duplicate of the first button you made. 

· Go to the Down state (frame) and delete the sun graphic. 

· From the library, drag in the copy b, movie button you just finished making. You can line up the center crosshairs with the arrow keys. 

· Go back to Scene 1 (upper left). Now your movie button has an animated down state. 

· Test your movie. 

· See Example 3 in the Flash Examples section of this tutorial for the finished product. 

Congratulations, you have made a button with a movie in it! 

Using Symbols in Flash MX
One of the most efficient ways to use Flash MX is to use symbols whenever you need more than one occurrence of a graphic, or animation or sound. A symbol is a graphic, button, movie clip, or sound that you create once, then reuse in your movie or other movies. Flash allows you to have an item saved in the Library that you can pull out onto your stage over and over again without busting your file size budget. You can also modify certain parameters on each instance such as scale, rotation, alpha and overall color. If you modify the symbol, it will change all the instances, but if you modify the instance, then just that instance is affected.

Symbol Types 

· Movie Clip - A symbol that can include animation(s), buttons, graphics, other symbols, and operates independently of the main stage Timeline. 

· Button - A symbol that allows interactivity and that responds to mouse clicks or rollovers. Buttons can also have movies placed in one of the states. 

· Graphic – A symbol that is used for static images or is controlled by main stage Timeline. Interactive controls and sounds won't work in this symbol. 

· Sound - The Sound symbol is created automatically when you import a sound. 

· Font - Create this type of symbol from the Library window options so you don't have to embed fonts in your site. 

Naming conventions
     The Library stores symbols in alphabetical order. In order to keep symbol types grouped together, name each symbol using the first letter of the type of symbol that is it first, followed by a comma, then the name of the symbol. When you are working with many symbols, this helps you find the particular symbol quickly and consistently. 

Example: 

· g, balloon 

· m, balloon movie 

· s, balloon squeaky sound 

· b, balloon button 

· ac, balloon movement action script in movie 

Exercise:
1. Create a simple shape on the stage, such as a red balloon. 

2. Let's save this shape into the Library by making the balloon a graphic symbol. 

· Using the Arrow tool, draw a selection box around the whole balloon. 

· With it selected, from the Insert menu, choose Convert to Symbol. 

· A Symbol Properties dialog box appears with 3 Behavior options. Flash defaults to the Movie Clip behavior. 

· Select the Graphic behavior. 

· Name your symbol: g, balloon. Click OK.

3. Delete the balloon from the stage. 

4. From the Window menu, choose Library. You'll see your balloon symbol in the Library window. 

5. Drag the balloon symbol (g, balloon) out of the library onto the stage. 

6. Now you have an “instance” of the balloon on the stage. 

7. Let's change the appearance of the balloon instance. 

· Using the properties menu, change the alpha to 50%, change the tint, and change the scale and rotation. 

8. You'll see the original symbol is unaffected. You can keep pulling in the same symbol over and over again but change each instance any way you want. These attributes can also be changed for different keyframes. 

Note: If you plan on animating each instance independently, put each instance on a separate layer. Animation requires "tweening", which will only work on one symbol on one layer at a time.

Making a movie symbol from the balloon graphic symbol
· From the Insert menu, choose New Symbol. 

· Choose Movie Clip as the Behavior if it's not already selected, and name your symbol: "m, balloon movie." Click OK. Movie symbols have their own timeline. This can get confusing. 

· You are now in the symbol editor, which looks just like the stage (because it has its' own independent timeline). One way you can tell you are in symbol editing mode is by looking at the upper left hand corner, which will have the movie symbol you just named after the scene name. 

· In the Library window, drag the "g, balloon" symbol out onto the m, balloon movie stage. 

· Select frame 10 on your timeline and then from the Insert menu, choosing Keyframe from the top menu. (Keyframe will duplicate the last keyframe with something in it.) 

· Move the animation scrubber to the second keyframe and select the balloon or click on that frame (this will pick everything in that keyframe). 

· Modify the balloon instance by rotation, scale, alpha and/or color. 

· Now we need to create a "tween" between the first keyframe and the second keyframe. To do this: 

· Click in the Timeline somewhere between the first and second keyframes. 

· In the property inspector, select the Motion option from the Tween dropdown menu. You can only use the motion tween on symbols. You can also add automatic rotation, easing, and other options at this point in the frame window. 

· There should be an arrow displayed in the Timeline area between the two keyframes. If you select something else, the motion tween should show up on a light blue field. (Shape tweens are green.) 

· Now if you scrub through the frames, you'll see the balloon changing smoothly from frame to frame. 

· Let's make this action loop continuously. To do that, let's assign an action to the last keyframe, telling it to return to the first frame of its Timeline again. 

· Click on the last frame and choose window>actions, the Frame Actions dialog box appears. 

· Make sure you are in normal mode in the Frame window. (check upper right pull-down arrow) 

· Click on the "Actions" book display action catagories, select the "Movie Controls" book and find GoTo. It will default to frame 1, which is fine. Now, the movie will loop continuously. 

· See Example 4 in the Flash Examples section of this tutorial. 

Button Symbol 

· Now we will make a button using both the g, balloon and the m, balloon movie. The button symbol has 4 default states: Up, Over, Down and Hit. These states reflect what's happening when the button is doing nothing, when the mouse is over it, when the mouse clicks on it, and the hit zone for the button. 

· Go back to the main stage. 

· From the Insert menu, choose New Symbol. 

· Choose Button option and name it: 'b, balloon.' You are now in the symbol editing mode again. 

· Select the “Up” frame. Drag the g, balloon symbol from the Library onto the stage. This is what the button will look like “at rest.” 

· For the "Over" state, we want the exact same position, but another color, so we're going to copy the “Up” frame and paste it into the “Over” frame (or, click to select the "over" frame and hit F6, or you can also just choose Keyframe from the Insert menu, and it will copy the contents of the last keyframe). 

· change the color of the balloon using the property inspector. 

· Now when you rollover this button, it will change color. 

· Next, select the “Down” keyframe area. From the Insert menu, choose Keyframe and drag in m, balloon movie from the Library. 

· For the “Hit” area, it doesn't show at all, so you can use the symbol or draw a hit area in this state. 

Your button is created now. Let's test it. 

· Go back to Scene 1 and drag your new “b, balloon” out onto the stage. 

· Test your button by choosing Test Movie from the Control menu. 

· See Example 5 in the Flash Examples section of this tutorial. 


Congratulations! You've made a movie, and a button with a movie in it!

Animating in Flash
Animation in Flash is easy! Let's look at a couple of different ways to achieve animation in Flash.

We built tweens in the “Button and Symbols making" tutorial, but let's do a quick review.

Shape Tween
	· Draw a shape at frame 1.
(Try a simple shape, like a heart.) 

· Insert a blank keyframe at frame 30 in the Timeline. Draw another shape (like a star) in a different color at frame 30. The two shapes should be on the same layer. Click on the area between the two frames in the Timeline. The area will turn black. 
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	· Now, open the Frames panel and choose Shape Tween. A light green bar with a solid arrow will appear between the two frames. When you scrub back and forth in the Timeline, the heart morphs to the star, and changes color.

· See Example 6 in the Flash Examples section of this tutorial for a finished product. 


Motion Tween
· Create a symbol or pull one out of the Library onto a new layer on frame 1. 

· Insert a keyframe at frame 30. This will keep the symbol on frame 30. 

· Modify the symbol by changing the position, scale, rotation, and alpha. (Use the Effects panel for the alpha). Select the area between the frames on the timeline and it will turn black. 

· Open the Frames Panel and choose Motion Tween. A light blue bar with a solid arrow will appear between the two frames. When you scrub back and forth in the Timeline, the symbol will move, scale, rotate and the alpha will change. 

· Motion Tween has other options. You can choose the direction of the rotation from the pull-down menu in the Frames Panel and have the tween automatically rotate the object the number of times you specify. 

· See Example 7 in the Flash Examples section of this tutorial for a finished product. 

Animations can be reused. For example, let's say you create an animation in a movie symbol of a bouncing ball. You could pull that ball out of the Library as many times as your computer can handle. You can put them all on independent layers, animate the position, scale, tint, alpha, etc. 

Animating along a Path
Let's say you want a small airplane to follow a path from the ground up to the clouds.

· Create a movie symbol of a little airplane with an animated propeller. 

· Drag the symbol out onto the stage. You may want to add a runway and some clouds in the sky to make your animation more complete. 

· Select the airplane layer and from the Insert menu, choose Motion Guide. This creates a new layer called a Guide Layer on top of the airplane layer. 

· Insert another keyframe in the Guide:airplane layer at the point where you want the motion to stop. 

· Using the Pencil tool, draw a curve that you want the airplane to follow from the runway to the clouds. (It won't show up in the movie) 

· Select the first keyframe in the airplane layer. Select the Arrow tool and move the airplane to the beginning of the curve. 

· Now select the last keyframe. Move the airplane along the curve to the end of the curve. 

· Double-click the first keyframe to open the Frame panel. Choose Motion from the Tweening menu and check Snap (snaps the registration point to the path). 

· Scrub along the Timeline, and the airplane will follow the curve from first to last frame. When you publish, the plane's propellers will move. (Movie animations do not display in Flash on the stage.) 

· See Example 8 in the Flash Examples section of this tutorial for a finished product. 

Frame by Frame Animation 

This is the most file-size intensive method, but sometimes it's the only way to get the effect you want.You can turn on a nifty feature called Onion Skinning to see surrounding frames so you can more accurately draw your frame.
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Exercise:
· In frame one, draw a dog. 

· In frame seven, from the Insert menu, choose Keyframe. This copies the dog from frame one through frame seven. 

· Insert a new layer above the dog layer. You can call it "feet." 

· Click on the Onion Skin icon from the options under the Timeline. You will see a faded version of the first frame. 

· Click and move each of the dog's legs.
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· If you like, you can continue to do this for another few frames for the eye lids and the tail. 

· Turn off the Onion Skin button. 

· Now scrub through your animation. You now have a dancing, tail-wagging winking dog. 

· See Example 9 in the Flash Examples section of this tutorial for a finished product. 

Using Sound in Flash MX
There are several ways to use sound in Flash MX. You can loop sounds to play continuously, independent of the timeline, or synchronize your sounds to an animation. You can import and edit your sounds in the Sound Panel.

Importing
Import sounds into Flash by choosing Import from the File menu. The following audio file formats can be imported into Flash:

· WAV 

· AIFF 

· MP3 

If you have QuickTime 4 or higher, you can also import these file formats:

· Sound Designer II (Macintosh) 

· Sound Only QuickTime Movies (Macintosh and Windows) 

· Sun AU (Macintosh and Windows) 

· System 7 Sounds (Macintosh) 

· WAV (Macintosh and Windows) 

Flash stores audio files in the Library as a symbol along with the graphics, movies and buttons. Sound files are indicated by a loudspeaker icon. Because the sound is a symbol, you only need one copy of it and you can use it in many ways in your Flash movie. In the Library and on the Timeline, audio files are represented as sound waves. 

Two types of sounds in Flash -- event sounds and stream sounds
· Event sounds must download completely before they start playing and they will continue playing until explicitly stopped (usually by a stop action). Event sounds are associated with an event such as a mouse click, and are independent of the Timeline. 

· Stream sounds begin playing as soon as there's enough data to play. These sounds are synchronized to the timeline. Flash forces the animation to keep in sync with the sound. If it can't draw frames fast enough, Flash will drop frames to keep the sound in sync. 

Editing with the Sound Panel
The Sound Panel allows you to modify the properties of the selected sound, for example:

· specify if the sound is an Event or Stream 

· start a new sound, or Stop the sound 

· apply effects to the sounds, such as None (which strips any previous effects off the sound), Fade In or Out, Left to Right, etc. 

· If you choose Custom, you can modify the in and out points of the fade, the duration, etc. in the window that opens up. Click on the boxes at the corners of each channel and also add points along the line by clicking. 

Exercise:
· Import a sound file by choosing Import from the File menu. You can download a sample .wav file named slide_whistle_3x.wav. If you have Flash you can download the finished sound.fla file. If you don't have Flash, a 30-day trial version is available at Macromedia.
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· Open the Library Panel, and click on the sound symbol you just imported. You will see it in the Library window with a play arrow. You can listen to the sound you just imported by clicking on the arrow at the top right of the Library window. 

· Name and select layer: Sounds 

· Add keyframes at frame 1 and frame 45 (or somewhere on the Timeline past the duration of the sound). It's not necessary to do this, but it gives you a look at the file in the Timeline. 

· Drag the sound onto the stage. You should see it on the layer as a waveform. You can get a better look at this by increasing the height of your layer. 

· From the Modify menu, choose Layer.
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· At the bottom of this window, you can change the layer height. Change it to 200% and click OK. 

· Open the Sound Panel. Select the sound on the Timeline. The information about that sound file will show up in the Sound Panel. It will also be visible in the top pull-down menu. If you have other sounds imported, they will be in the menu also. You can change the sound file you're editing from here. Directly under that you will see the sound file information, MHz and file size. 

You can apply different effects to your sound
1. None - choosing this will remove any previous effects 

2. Left channel 

3. Right channel 

4. Fade left to right 

5. Fade right to left 

6. Fade in 

7. Fade out 

8. Custom – when you choose this, another window will open, allowing you to edit both audio channels. 

The edit button opens up the same audio channel editor. Choose each effect, open the editor and look at each effect. If you click in one of the channels, it will change to Custom, but these effects can be used as starting points to get the effect you want or use them as is.
The best way to get a feel for the sound editor is to apply each effect to your sound, listen to it and try some things in the custom effect editor.

Below the effects panel is the sync menu. It has the following options:

1. Event – associated with specific actions, not tied to the timeline (like a sound accompanying a mouse click) 

2. Start – same as Event, but will create a new instance of that sound if it is already playing. 

3. Stop – stops the specified sound 

4. Stream – syncs the sound with the animation, forces the animation to play at the same rate as the sound, dropping frames if necessary. 

You can loop the sound the number of times you type in the box. Don't loop streaming sound; it will increase your file size dramatically.

Have fun! 

Saving and Publishing in Flash MX
Saving Flash movies
To save your working site with all its layers, animations, etc. from the File menu, choose Save. Flash will save it as a Flash movie with a .fla extension. This is similar to Photoshop where you save your working site with all its layers, channels and text as a .psd file. Archive this file. When you're ready to show your creation to the world, you must publish or export your .fla file into a file format that will play back on the Web or be viewed as a still image or a series of images.

Publishing Flash movies on the World Wide Web
One of the most popular ways to make your multimedia project available to the world is by putting it on the World Wide Web. An easy way to accomplish this is by choosing Publish Settings from the File menu. The Publish command creates the Flash Player file (SWF) and the HTML document that inserts your Flash Player file into a Web browser.

To publish your Flash project, first click Publish then OK.

This dialog box gives you the opportunity to create different file formats -- GIF, JPEG, PNG, and QuickTime -- and the HTML needed to display them in the browser window. These alternative formats enable a browser to display your movie's animation and interactivity for users who don't have the Flash Player installed. 

Be creative and have fun with Flash!
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